wordpress + woocommerce + chrome + SSL的问题

刚把谷歌浏览器升级到最新版就发现问题了,目前Chrome 的版本应该是:Chrome version 44+。用最新版的Chrome浏览wordpress+woocommerce的网站时会自动强制用HTTPS/SSL,所有的域名都变为https了。其它浏览器都是正常的,郁闷的很。

各种搜索之后,终于问到了解决方法,都是最近发现的事情。

 

这是一篇在wordpress.org讨论此问题的贴子:

https://wordpress.org/support/topic/site-broken-in-chrome-ssl-issue?replies=57

 

这是某个博主的解决方案与记录:

http://frique.me/blog/chrome-wordpress-ssl-bug/

在你的主题模板的functions.php加入一句就行了

/ In your theme / a plugin's functions.php: 
$_SERVER['HTTPS'] = false;

此种方法就是强制不用HTTPS。

 

另外WooCommerce 2.3.13也已经解决了此问题,更新到WooCommerce最新版本就行。

http://develop.woothemes.com/woocommerce/2015/07/woocommerce-2-3-13-security-and-maintenance-release/

 

 

~完。

5 回复

评论已关闭。